Pearson MyLab Outage
Incident Report for Campus Technology Services Status
Resolved
This incident has been resolved.
Posted Apr 13, 2022 - 19:45 EDT
Identified
We were just informed about a system-wide outage for MyLab (not specific to Inclusive Access).

Pearson teams are working with the highest priority to restore service. Messaging and updates are posted to the Pearson Support website(https://support.pearson.com/getsupport/s/contactsupport) and via Twitter @PearsonSupport.
Posted Apr 13, 2022 - 14:55 EDT