Banner outage

Incident Report for Campus Technology Services Status

Resolved

At approximately 1:30 p.m. today, Campus Technology Services (CTS) resolved the issue. Banner is working as expected. Thank you for your patience with this matter.

If you have any questions or concerns related to this outage, please contact CTS.


Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted May 27, 2026 - 15:34 EDT

Investigating

Starting at 11:30 a.m., today, May 27, Banner became unavailable to everyone on and off campus. Banner admin pages are non functional, but myOswego continues to function. Campus Technology Services (CTS) is working to resolve the issue as quickly as possible.

Further updates will be posted to the Campus Technology Services (CTS) status page.

If you have any questions or concerns related to this outage, please contact CTS.


Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted May 27, 2026 - 12:54 EDT