Seneca Hall second floor is back online as of 10:20 a.m. today.
CTS technicians have resolved all connectivity issues this morning. Wired and wireless networks are now working as expected. Any printers showing as offline or are not printing should be power cycled.
Thank you for your patience.
If you have any questions or concerns related to this outage, please contact CTS.
Onondaga Hall is back online as of 9:45 a.m. today.
Further updates will be posted as they become available.
Posted Jul 28, 2025 - 10:10 EDT
Update
Rich Hall first floor is back online as of 9:50 a.m. today.
Further updates will be posted as they become available.
Posted Jul 28, 2025 - 09:53 EDT
Update
Park Hall was brought back online at 8:45 a.m. today.
Further updates will be posted as they become available.
Posted Jul 28, 2025 - 08:50 EDT
Identified
Starting at approximately 9:30 p.m. Saturday, July 26, the network became unavailable on campus due to a power failure. Several residence halls and academic buildings lost network connectivity.
At approximately 12:00 a.m. Sunday, July 27, power to the campus was restored. As a result of this event, there are a few outstanding network outages Campus Technology Services (CTS) has identified and is working to resolve:
Rich Hall first floor Park Hall Seneca 2nd floor Onondaga Hall
Technicians are working on resolving these issues as quickly as possible.
For all other areas, any printers showing as offline or are not printing will need a power cycle.
If you have any questions or concerns related to this outage, please contact CTS.