iClicker software licensing issue

Incident Report for Campus Technology Services Status

Resolved

Starting at approximately 12:30 p.m. yesterday, Aug. 25, Campus Technology Services (CTS) became aware of a licensing issue with the iClicker software installed on podium computers in on-campus classrooms and faculty and student computers. Launching the software resulted in a message saying the subscription had expired. At approximately 1 p.m. today, Aug. 26, CTS resolved the issue. The iClicker software is working as expected.

Thank you for your patience.
Posted Aug 26, 2025 - 13:15 EDT

Monitoring

We believe this issue is now resolved and are continuing to monitor it.
Posted Aug 26, 2025 - 12:44 EDT

Identified

CTS continues to work on resolving the iClicker issue. Some students may also be experiencing the same issue.
Posted Aug 26, 2025 - 08:03 EDT

Investigating

Starting at approximately 12:30 p.m. today, Aug. 25, Campus Technology Services (CTS) became aware of a licensing issue with the iClicker software installed on podium computers in on-campus classrooms and some faculty computers. Launching the software results in a message saying the subscription has expired. CTS is working to resolve the issue as quickly as possible.

Further updates will continue to be posted on this status page.

If you have any questions or concerns related to this outage, please contact CTS.

Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Aug 25, 2025 - 18:53 EDT