HelioCampus Service Interuption
Incident Report for Campus Technology Services Status
Resolved
The problem has been resolved. All instances of the platform should now be accessible.
Posted Jan 07, 2025 - 13:36 EST
Investigating
Production instances of the platform are currently slow or inaccessible for some clients. We are diagnosing the issue and will send an update when we have further information. This is the platform that contains data for Student Evaluations of Teaching (SET).
Posted Jan 07, 2025 - 09:59 EST