Outgoing Phone Call Service Outage

Incident Report for Campus Technology Services Status

Resolved

Starting at approximately 3:00 p.m. today, Sept. 25, outgoing phone calls became unavailable from on-campus. Outgoing call service came back online around 4:15 p.m. today, and the service is working as expected.

If you have any questions or concerns related to this outage, please contact CTS.

–
Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Sep 25, 2026 - 16:23 EDT

Identified

Starting at approximately 3:00 p.m. today, Sept. 25, outgoing phone calls became unavailable from on-campus. Campus Technology Services (CTS) has communicated this outage to our service provider, who is working to resolve the issue as quickly as possible.

If you have any questions or concerns related to this outage, please contact CTS.


–

Campus Technology Services

help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Sep 25, 2026 - 15:46 EDT