Issues accessing campus services via CAS login

Incident Report for Campus Technology Services Status

Resolved

Campus Technology Services (CTS) has resolved the issue at 2:30 p.m. today. If you have any further questions, please contact the CTS Helpdesk.
Posted Aug 31, 2026 - 14:36 EDT

Investigating

Starting at approximately 12:00 p.m. today, Aug. 31, our CAS authentication service became unavailable to everyone from both on and off campus. This is impacting the ability to log in to several university systems, including but not limited to:

InterviewExchange
Academicworks
Qualtrix
Any other application using a “https://cas-prod.oswego.edu/” web address to log in

Campus Technology Services (CTS) is working to resolve the issue as quickly as possible.

If you have any questions or concerns related to this outage, please contact CTS.


Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Aug 31, 2026 - 13:46 EDT