Service Alert - WileyPLUS Log in Issue

Incident Report for Campus Technology Services Status

Resolved

We are pleased to report that the previous issues WileyPLUS was experiencing have been resolved. We apologize for any inconvenience you may have experienced as a result.
Posted Sep 18, 2023 - 15:27 EDT

Monitoring

Some customers are experiencing issues logging into WileyPLUS. We continue to experience technical issues with customers' ability to log in and are still actively working to resolve the issue. Thank you for your patience. We apologize for any inconvenience this may cause. Please check back for updates. For more information visit the WileyPLUS status page: https://status.wileyplus.com
Posted Sep 18, 2023 - 14:24 EDT