Banner Outage

Incident Report for Campus Technology Services Status

Resolved

After monitoring the service this morning, the Banner document management service is working as expected.

Thank you for your patience.

If you have any questions or concerns related to this outage, please contact CTS.


Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Jun 24, 2025 - 09:57 EDT

Monitoring

Starting at approximately 9 a.m. today, Jun. 23, the Banner document management service became unavailable from on and off campus. Accessing documents results in a "Unable to display the current page" error message. At approximately 4:00 p.m., the service should be working as expected, however Campus Technology Services (CTS) will continue to monitor it.

Our next update will be tomorrow morning, Jun. 24.
Posted Jun 23, 2025 - 16:10 EDT

Investigating

Banner Document Management (BDM) is currently unavailable in both Admin Pages and myOswego. Periodic access issues began around 9:00 a.m. this morning and are ongoing. We are currently working on diagnosing the cause of the issue and will update this page with more information as it becomes available. If you have any questions or concerns, please contact the CTS Help Desk at help@oswego.edu.
Posted Jun 23, 2025 - 15:24 EDT