Web Services Access Issue

Incident Report for Campus Technology Services Status

Resolved

Starting at approximately 3:11 a.m. yesterday, Oct. 20, users experienced significant slowness, connection errors, or intermittent outages while attempting to access some web services from on and off campus. Affected web services included, but were not limited to:
Brightspace
Jaggaer
myOswego
Adobe products
Slate
Zoom
Panopto
Textbook publishers (and associated courseware)

At approximately 6:53 p.m. yesterday, the Amazon Web Services (AWS) infrastructure issue was resolved. Affected services should now be operating as expected.

If you have any questions or concerns related to this outage, please contact Campus Technology Services (CTS).


Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Oct 21, 2025 - 08:29 EDT

Update

Starting at approximately 3:11 a.m. today, Oct. 20, users experienced significant slowness, connection errors, or intermittent outages while attempting to access some web services from on and off-campus. The disruption is caused by a major, ongoing Amazon Web Services (AWS) infrastructure issue. Affected web services include but are not limited to:
Brightspace
Jaggaer
myOswego
Adobe products
Slate
Zoom
Panopto
Textbook publishers (and associated courseware)

If you experience any issues, please be patient and try again.

Campus Technology Services (CTS) will continue to monitor the outage. Further updates will be posted to the CTS status page.

If you have any questions or concerns related to this outage, please contact CTS.


Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Oct 20, 2025 - 16:11 EDT

Monitoring

Starting at approximately 3:11 a.m. today, Oct. 20, Brightspace users experienced significant slowness, connection errors, or intermittent outages while attempting to access the platform from on and off-campus. The disruption is caused by a major, ongoing Amazon Web Services (AWS) infrastructure issue reported by D2L. At 6:35 a.m. Amazon reported that the issue was mitigated, and as of 8:48 a.m. our SUNY Oswego instance started reporting resolved site issues. We will continue to monitor the outage.

If you are still experiencing any issues, be patient and check for updates.

If you have any questions or concerns related to this outage, please contact CTS.


Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Oct 20, 2025 - 09:06 EDT