The update was confirmed to be applied successfully.
Posted Oct 07, 2025 - 08:09 EDT
Update
In partnership with our vendors, an update will be applied overnight tonight, Oct. 6, that should permanently resolve the issue. While we are not expecting any errors or outages during this time, we want to alert the campus that this update is taking place.
Posted Oct 06, 2025 - 09:27 EDT
Update
We are continuing to monitor the situation and working with vendors towards a permanent resolution to the problem. Thank you for your continued patience.
Posted Oct 03, 2025 - 16:30 EDT
Update
At approximately 10:00 a.m. today, Friday, Oct. 3, a temporary solution was applied to resolve the issue. Google Workspace is now working as expected. New files can be created, and existing files can be edited. The “storage is full” error message should now be gone. We are monitoring the situation and diligently working with our vendors for a permanent resolution.
Further updates will be posted as we receive them. Thank you for your patience.
Posted Oct 03, 2025 - 12:20 EDT
Monitoring
A fix has been implemented, and we are monitoring the situation. Further updates will be posted shortly. We appreciate your patience as we work towards a solution to this matter.
Posted Oct 03, 2025 - 10:37 EDT
Update
Starting Thursday evening at approximately 8:30 p.m., Oct. 2, Google Workspace services became partially disabled to the entire campus due to a storage is full error. As a result, new files cannot be created in any Google Workspace application (Google Docs, Sheets, Slides, Classroom, etc.), and existing files cannot be edited. Email is still functional and not impacted.
As of this morning, Friday, Oct. 3, the storage error is still present. Google has escalated the issue. Campus Technology Services (CTS) is working to restore service as quickly as possible.
Further updates will be posted as we receive them. We appreciate your patience as we work through this issue.
Posted Oct 03, 2025 - 08:32 EDT
Identified
Starting Thursday evening, Oct. 2, Google Workspace services became partially disabled to the entire campus due to a storage is full error. As a result, new files cannot be created in any Google Workspace application (Google Docs, Sheets, Slides, Classroom, etc.). Email is still functional and not impacted. Google has escalated the ticket and is looking into the issue, but there is no timetable for a resolution. We will post updates as we receive them.