Campus power outage causing network issues

Incident Report for Campus Technology Services Status

Resolved

At approximately 12:00 a.m. today, July 27, power to the campus was restored. The network is now working as expected.

Thank you for your patience.

If you have any questions or concerns related to this outage, please contact CTS.


Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Jul 27, 2025 - 07:59 EDT

Identified

Starting at approximately 9:30 p.m. today, July 26, networking equipment began to power down. It was discovered that this was due to a power failure on campus. Several residence halls and academic buildings have been affected.

Campus Technology Services (CTS) is aware of the problem and is monitoring the issue. Further updates will be posted to the Campus Technology Services (CTS) status page.

If you have any questions or concerns related to this outage, please contact CTS.
Posted Jul 26, 2025 - 23:12 EDT