Nationwide Issue Affects Campus Servers and Windows Computers
Incident Report for Campus Technology Services Status
Resolved
Since the morning of July 19, Campus Technology Services (CTS) has identified and is actively responding with in-person technical support for a nationwide CrowdStrike update issue affecting Windows computers that were left on at the time of the update on July 19 at 12 a.m. Affected computers are presented with a blue screen and cannot log in. CTS has worked diligently to update campus Windows desktops and lab machines and restore services. At this time, all classrooms and labs with events scheduled this week are updated, and LakerPrint and other services have been resolved.

Next Steps - What you should do:

Anyone whose University-owned Windows device was affected, please contact CTS. We will work to prioritize fixing your machine. University-owned Windows laptops should be brought to the CTS Help Desk at 26 Lanigan Hall to correct the issue.

If any Faculty/Staff printers have errors, please attempt to reboot them.

We caution employees not to click on malicious links through communications from anyone identified as CrowdStrike. There have been reports that hackers have used this situation to phish or social engineer through social media to gather your personal information. All official communications will come from CTS.

If you have any questions or concerns about this outage, please contact CTS.
Posted Jul 22, 2024 - 13:07 EDT
Identified
Early this morning, Campus Technology Services (CTS) identified the Windows screen issue and is actively responding with in-person technical support. CTS has worked throughout the day to update campus Windows desktops and labs. All Help Desk tickets have been resolved, or individuals have been contacted.

Services restored include:
Document Management
Room scheduling and viewing of events
Faculty and staff printing
InterLibrary Loan system
Citrix
Faculty/Staff printers with errors please attempt to reboot.
LakerPrint is still unavailable and CTS is working on it.

Next Steps - What you should do:
Anyone whose Windows device was affected please contact CTS. We will work to prioritize fixing your machine.
If your machine does not work when you next arrive on campus, please contact CTS and we will work to resolve your issue.
University-owned Windows laptops should be brought to the CTS Help Desk at 26 Lanigan Hall to correct the issue. The Help Desk will open early at 7 a.m. Monday, July 22.

We caution employees not to click on any malicious links through communications from anyone identified as CrowdStrike. There have been reports that hackers have been using this situation to phish or social engineer through social media to gather your personal information. All official communications will come from CTS.

Further updates will be posted to the Campus Technology Services (CTS) status page.

If you have any questions or concerns related to this outage, please contact CTS.
Posted Jul 19, 2024 - 15:07 EDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 08:52 EDT
Investigating
Starting today (July 19) at approximately 1 a.m., many campus Windows devices were presented with a blue screen preventing users from logging in. The blue screen says “Your PC ran into a problem and will need to restart. We’re just collecting some error info, and then we’ll restart for you.” Many services became unavailable from on-campus and off-campus.

This is a part of a nationwide issue caused by a CrowdStrike update error. Campus Technology Services (CTS) is working to resolve the issue as quickly as possible.

Further updates will be posted to the Campus Technology Services (CTS) status page.

If you have any questions or concerns related to this outage, please contact CTS.


Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Jul 19, 2024 - 08:38 EDT