As of 9:00 p.m. this evening, all systems are fully operational, and we have resolved this incident. We appreciate your patience as we worked to address the issue.
Posted Jan 27, 2025 - 22:35 EST
Identified
January 27th 2025, 5:06pm EST We apologize for the technical issue impacting course access via Third-Party Learning Management systems. Technology teams are engaged and working to restore services: we appreciate your patience and will provide an update when new information becomes available.
Posted Jan 27, 2025 - 18:00 EST
Investigating
Pearson is reporting some server issues that are causing delays and timeouts when accessing their products. Affected products include:
Here are the latest messages from Pearson, we will send updates as they become available:
January 27th 2025, 1:15pm EST Some customers using Third-Party Learning Management Systems may experience a 504 Error message when attempting to access courses. We are working to restore services and will update you in 60 minutes.
January 27th 2025, 2:39pm EST We apologize for the technical issue impacting course access via Third-Party Learning Management Systems. Some customers may experience a delay or various error messages. We appreciate your patience and will provide an update when new information becomes available.