HelioCampus browser issue

Incident Report for Campus Technology Services Status

Resolved

The login issue affecting Firefox and Safari browsers has been resolved. Users can now access your site using these browsers without any issues.
Posted Jan 28, 2025 - 10:31 EST

Monitoring

Some users are experiencing errors when using Safari or Firefox to access HelioCampus. The vendor is currently investigating this problem. We encourage students and faculty to use Chrome or Edge as a workaround to access the platform.
Posted Jan 23, 2025 - 15:50 EST