myOswego "Check your registration time" issue

Incident Report for Campus Technology Services Status

Resolved

Starting at approximately 8 a.m. yesterday, Oct. 13, the myOswego "Check your registration time" service became unavailable to students from on and off-campus. Clicking on the link for this service from within myOswego results in an unresponsive result.

At approximately 7:50 p.m. yesterday, Oct. 13, the issue was resolved. Checking registration time is working as expected.

Thank you for your patience.

If you have any questions or concerns related to this outage, please contact CTS.


Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Oct 14, 2025 - 14:43 EDT

Monitoring

As of approximately 7:50 p.m., we believe the issue is resolved. Additional tests will be conducted in the morning to further ensure it is resolved.
Posted Oct 13, 2025 - 20:38 EDT

Identified

Starting at approximately 8 a.m. today, Oct. 13, the myOswego "Check your registration time" service became unavailable to students from on and off-campus. Clicking on the link for this service from within myOswego results in an unresponsive result. Campus Technology Services (CTS) is working to resolve the issue as quickly as possible.

Further updates will be posted here on this IT Status page.

If you have any questions or concerns related to this outage, please contact CTS.


Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Oct 13, 2025 - 16:44 EDT