Campus network outage
Incident Report for Campus Technology Services Status
Resolved
This incident has been resolved.
Posted Aug 11, 2023 - 08:10 EDT
Monitoring
At approximately 3:35 p.m., the campus experienced a network outage. At approximately, 3:50 p.m. the issue was resolved. While you should be able to connect to services, there may be some slight network delays loading the services. If you are unable to access any services, try rebooting your computer.

We will be monitoring the service for stability.
Posted Aug 10, 2023 - 15:53 EDT