Issues accessing campus services via CAS login

Incident Report for Campus Technology Services Status

Resolved

Starting today, Jan. 20, at approximately 9:51 a.m., Campus Technology Services (CTS) became aware of technical difficulties with our Central Authentication Service (CAS). This is impacting the ability to log in to several university systems from both on and off-campus, including but not limited to:

Qualtrics
Blackbaud
Interview Exchange
Any other application using a “https://cas-prod.oswego.edu/” web address to log in

At approximately 2:32 p.m. today, Jan. 20, services to the campus were restored. The logins are now working as expected.

Thank you for your patience.

If you have any questions or concerns related to this outage, please contact CTS.


Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Jan 20, 2026 - 14:38 EST

Investigating

Starting today, Jan. 20, at approximately 9:51 a.m., Campus Technology Services (CTS) became aware of technical difficulties with our Central Authentication Service (CAS). This is impacting the ability to log in to several university systems from both on and off-campus, including but not limited to:

Qualtrics
Blackbaud
Interview Exchange
Any other application using a “https://cas-prod.oswego.edu/” web address to log in
Next Steps:
Do not attempt to repeatedly reset your password, as this is a system-wide issue and not related to individual accounts.
Further updates will be posted to the CTS Status Page.
If you have any questions or concerns related to this outage, please contact CTS.

Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Jan 20, 2026 - 11:36 EST