Microsoft Cloud Authentication Service Interruption

Incident Report for Campus Technology Services Status

Resolved

As of 8:00 p.m. yesterday, Oct. 29, Microsoft reported that the issue has been resolved. If you experience any further issues, please contact the CTS Help Desk.


Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Oct 30, 2025 - 08:17 EDT

Monitoring

Starting at approximately 12:00 p.m. today, Oct. 29, Microsoft cloud authentication services became unavailable or very slow both on and off campus. As of 4 p.m. today, Microsoft is still actively investigating and is working to resolve the issue as quickly as possible.

Further updates will be posted to the Campus Technology Services (CTS) status page.

If you have any questions or concerns related to this outage, please contact CTS.


Campus Technology Services
help@oswego.edu | 315.312.3456 | 26 Lanigan Hall
Posted Oct 29, 2025 - 16:28 EDT

Identified

Starting at approximately 12:00 p.m. today, Oct. 29, Microsoft authentication services became unavailable or very slow both on and off campus. Microsoft is actively investigating and is working to resolve the issue as quickly as possible.
Posted Oct 29, 2025 - 13:05 EDT