Oswego.edu websites not loading
Incident Report for Campus Technology Services Status
Resolved
At approximately 4:20 p.m. today, May 8, the campus experienced a technical issue loading some campus websites. While the main www.oswego.edu website loaded, some sites would not load giving a “Temporarily Unavailable” message. At approximately 6:10 p.m., the issue was resolved.
Posted May 08, 2023 - 20:31 EDT
Investigating
We are currently investigating an issue where some oswego.edu websites are not loading, including Brightspace.
Posted May 08, 2023 - 16:34 EDT